Forum >> Programmazione Python >> Calcolo scientifico >> Verifica della multimodalità di una distribuzione

Pagina: 1

Salve,
esiste un pacchetto in python per verificare se una distribuzione statistica è multimodale? In particolare ho una distribuzione di dati che sembra essere "bimodale" e vorrei una verifica con un test numerico-statistico di tale caratteristica.







Grazie,







Antonio
Mah, questo è uno dei (frequenti) casi in cui mi arrendo e googlo come un niubbo qualsiasi. Non so se Numpy/SciPy/Pandas/whatever hanno già strumenti per questo. Ma è possibile che questo https://github.com/YeoLab/anchor faccia al caso tuo...
https://leanpub.com/capirewxpython : Capire wxPython, il mio libro
https://pythoninwindows.blogspot.com : Python in Windows, il mio blog e le mie guide
Grazie,
questo pacchetto l'avevo già trovato in rete e stavo provando ad utilizzarlo, ma non riesco a farlo funzionare!




Nell'installazione windows mi da il seguente errore:





C:\Users\Utente\Desktop\EP&R\Script-post-processing EP&R\Mappe statistiche>python createbaseArpege I step.py F:\Krsko\Arpege\PUFF\Cs-137\ST_1.0E+16\2002 Krsko deptot Cs-137 220 1.0E+16

Traceback (most recent call last):

File "createbaseArpege I step.py", line 6, in <module>

import anchor

File "C:\Python27\lib\site-packages\anchor\__init__.py", line 3, in <module>

from .binning import BinnedModalities

File "C:\Python27\lib\site-packages\anchor\binning.py", line 4, in <module>

from .infotheory import binify, bin_range_strings, jsd

File "C:\Python27\lib\site-packages\anchor\infotheory.py", line 7, in <module>

from sklearn import cross_validation

ImportError: cannot import name cross_validation





nell'installazione linux, l'errore che ho allegato.




Ciao,




Antonio





Allegati
eh, non è mantenuto da un sacco di tempo. E da quel che vedo https://github.com/YeoLab/anchor/blob/master/requirements.txt l'autore commette l'errore capitale di non "pinnare" le dipendenze... quindi se adesso lo installi normalmente con pip e nel frattempo qualcosa è cambiato nelle dipendenze, può introdurre errori, anche se al tempo della release non c'erano.


Se davvero ti interessa la faccenda puoi dare un'occhiata al sorgente e fare un po' di debug per conto tuo... oppure puoi continuare a cercare.





In ogni caso, davvero: SMETTI di usare python 2.7. Non so neanche più se tutto lo stack di quel pacchetto funziona con python 2.7 (ormai non ce l'ho più neanche installato, non posso provare).



https://leanpub.com/capirewxpython : Capire wxPython, il mio libro
https://pythoninwindows.blogspot.com : Python in Windows, il mio blog e le mie guide
Grazie,



provo a fare un pò di aggiornamenti e, se non riesco, installo python 3.0. Per ciò che riguarda le "dipendenze" non ci ho capito molto, sono un neofita del codice.







Grazie ancora,







Antonio









provo a fare un pò di aggiornamenti e, se non riesco, installo python 3.0. Per ciò che riguarda le "dipendenze" non ci ho capito molto, sono un neofita del codice.
Siamo alla versione 3.7.2.

Cya



Pagina: 1



Esegui il login per scrivere una risposta.